THiNQ Makerは 2020年12月31日でサポートを終了いたしました。詳細>>
現象
Internet Explorer11を利用しているが「Internet Explorerバージョン9以上をお使いください。バージョン8以前のInternet Explorerはサポート対象外です。」というアラートが表示されコンテンツの閲覧できない。
※同じPCでもChromeやFirefoxでは、問題なくコンテンツが閲覧できる。
THiNQ Maker 1.13.6 HTML5コンテンツの例
|
アラート後、表示される画面の例 |
回答
回答が2つあります。
回答(1)
原因
コンテンツがアップロードされているサーバー側でドキュメントモードの設定が行われているため、該当のアラートが表示されている可能性があります。
参考)ドキュメントモードとは、
コンテンツ掲載側のサーバー側で、Internet Explorerに対して、
古いInternet Explorerとしてで動作するように強制的な命令(ドキュメントモードの指定)です。
この設定が行われている場合、Internet Explorer"11"であったとしても、Internet Explorerが古いバージョンとしての振る舞いをするようになります。
確認方法
この原因に該当するかどうかは、以下の方法でご確認ください。
- Internet Explorerを起動します。
- 右上歯車マークをクリック
- 開発者ツールをクリック
- Internet ExplorerのURL欄に、該当のコンテンツのURLを入力
- 開発者ツールウィンドウの上部の表記を確認
「7」「8」が表示されている場合、この問題に該当します。
回避策
回避方法は2つ考えられます。
1)Internet Explorer11以外のブラウザでコンテンツを閲覧する
該当のアラートは、Chromeなどでは発生しません。
その為、他のブラウザをご利用になる事でコンテンツ閲覧が行えるようになります。
2)コンテンツをアップロードしているサーバー側の設定を調整する
サーバー側でドキュメントモードの設定を解除することで、問題解決が見込まれます。
お手数ですが貴社の情報システム部門の方とのご調整をお願い致します。
以下、情報システム部門の方への依頼の例文となります。
貴社内での調整で参考にして貰えましたら幸いです。
ーーーここからーーー
○○○○○○のサーバーにアップロードしているHTML5で動作する
コンテンツ(URL:****)
を閲覧しようとしたら、以下の様なアラートが表示されて閲覧できません。
コンテンツ作成ソフトの開発ベンダーに確認したところ、
ドキュメントモードの設定が影響していると、との回答を貰いました。
コンテンツがアップロードされているサーバー側の設定で
ドキュメントモードを解除することは可能でしょうか?
ーーーここまでーーー
発生条件
- Internet Explorerで発生します(ChromeやFireFoxでは閲覧できます)
回答(2)
原因
閲覧者のInternet Explorerで、互換性表示設定がされている可能性があります。
互換性表示とは、表示が崩れてしまうような古いWebサイトを閲覧するために、ブラウザが古い挙動をするように指定する設定です(Internet Explorerで設定します)。これが設定されていると、現象が起きる可能性があります。
回避策
以下の手順で互換性表示設定を確認し、設定されている場合は解除して現象が改善するか確認してください。
- Internet Explorerを開く
- 右上歯車マークをクリック
- 「互換性表示設定」をクリック
- 「互換性表示に追加したWebサイト」に該当コンテンツのドメインが追加されているか確認
- 追加されている場合は削除して動作が代わるか確認
※ PCクライアント側のInternet Explorerに互換表示設定がされていない場合、(該当のドメインが追加されていない)、Active Directoryの設定が影響していることがあります。貴社のシステム管理部門にご相談ください。
発生条件
- Internet Explorerで可能性があります(ChromeやFireFoxでは閲覧できます)