現象
FLIPPER U2で作成したデータをWebサーバーにアップし、該当のURLにアクセスするとブックが表示されない。
回答
回答は以下のとおりです。
- 回答(1)ブックデータがWebサーバーに全てアップロードされていない
- 回答(2)FTPツールの文字コードがShift_JISの状態でアップロードした
- 回答(3)Webサーバーの文字コード設定がShift_JISになっている
- 回答(4)WebサーバーがJPEG画像を圧縮する設定になっている
→ FLIPPER U2 ver5.0.5で改修済み - 回答(5)Internet Explorer 11のセキュリティレベルが「高」になっている
→ IE11は動作対象外です - 回答(6)Internet Explorer 9 以下で閲覧している
→ IE11は動作対象外です - 回答(7)Webサーバーの設定でIE9以下になっている
→ IE11は動作対象外です
回答(1)ブックデータがWebサーバーに全てアップロードされていない
原因
ブックデータがWebサーバーに全てアップロードされていない可能性があります。
作成したブックデータをWebサーバーにアップロードする際、一部のデータが欠けるとコンテンツが表示されません。
確認方法
データに欠けがないか確認するには、ネットワーク通信をモニタリングするツールを使うのが便利です。
ここではGoogle Chromeのデベロッパーツールを使って確認する方法を紹介します。
- 該当のブックURLにGoogle Chromeでアクセスします。
- 設定>その他のツール>デベロッパーツールを開きます。
- 「Network」が選択されている事を確認します。
- F5キーを押します。
- データが正常にアップロードされていない場合、赤いエラーが表示されます。
発生条件
データが欠けている場合、すべてのブラウザで表示されません。
回避策
再アップロードをお試しください。
回答(2)FTPツールの文字コードがShift_JISの状態でアップロードした
原因
FTPツールの文字コードがshift_JISの状態でWebサーバーにアップロードした可能性があります。
※この原因に該当している場合、ブラウザタブのタイトルが文字化けしている事があります。
回避策
文字コードを「無変換」や「自動」等に変更してください。
※FTPツールによって設定項目名は異なります。
▼以下はFFFTPの設定画面
発生条件
主要ブラウザ全てで発生します。
回答(3)Webサーバーの文字コード設定がShift_JISになっている
原因
Webサーバーの設定でHTMLの文字コード設定が、Shift_JIS に指定されている可能性があります。
回避策
- サーバーの設定を見直す方法
例えば、WebサーバーがApacheだった場合、サーバーの設定を見直してください。
具体的には、以下2種類の方法がございます。
※ サーバーの設定方法につきましてはサーバーを管理されている部門にお問合せください。
・サーバー全体の設定としてAddDefaultCharset を offにする
・.htaccessを設置し、デジタルブックのディレクトリだけAddDefaultCharset を offにする。
- ブック側を修正する方法
ブックデータ内のhtmlファイルを全て「shift-jis」に変更してください。
(<meta charset="UTF-8">のタグも合わせて削除)
回答(4)WebサーバーがJPEG画像を圧縮する設定になっている
原因
WebサーバーがJPEG画像を別の画像ファイル形式(例:webpなど)に自動変換したり、JPEG画像を圧縮するような設定になっている場合、一瞬ページが表示されたあとに真っ白で表示される事が分かっています。
回避策
FLIPPER U2 ver5.0.5で改修しております。
以下の手順でご対応ください。
- FLIPPER U2を最新バージョンにアップデートします。
- 該当ブックを再書き出しします。
- 書き出したデータをWebサーバーにアップロードします
原因(5)Internet Explorer 11のセキュリティレベルが「高」になっている
FLIPPER U2 ver5.0.2より、Internet Explorer 11は非推奨ブラウザになりました。
原因
Internet Explorer 11のセキュリティレベルが「高」になっている可能性があります。
回避策
セキュリティレベルを「中高」にする事で問題解決が見込まれます。
具体的な手順は以下の通りです。
- Internet Explorer 11を起動します
- ツール(歯車マーク)>インターネットオプション
- [ セキュリティ ]タブ内の「このゾーンのセキュリティのレベル」から変更します。
※セキュリティポリシーはお客様によって異なりますので、貴社の情報システム部門の方にご相談の上ご変更をお願いいたします。
発生条件
Internet Explorerで発生します(Google ChromeやFireFoxでは閲覧できます)
関連情報
Windows 10 の Internet Explorer 11 デスクトップアプリは 2022/6/15にサポートが終了します。
回答(6)Internet Explorer 9 以下で閲覧している
※ FLIPPER U2 ver5.0.2より、Internet Explorerは非推奨ブラウザになりました。
原因
推奨動作環境外のInternet Explorer 9 以下で閲覧している可能性があります。
確認方法
この原因に該当するかどうかは、以下の方法でご確認ください。
- Internet Explorerを起動します。
- ツールメニュー(右上歯車マーク)をクリック
- [バージョン情報]をクリック
回避策
動作環境に満たしたブラウザで閲覧してください。
[動作環境]
https://suite.logosware.com/flipper-maker/requirements/
発生条件
Internet Explorer9以下で発生します(Google ChromeやFireFoxでは閲覧できます)
関連情報
Windows 10 の Internet Explorer 11 デスクトップアプリは 2022/6/15にサポートが終了します。
回答(7)Webサーバーの設定でIE9以下になっている
※ FLIPPER U2 ver5.0.2より、Internet Explorerは非推奨ブラウザになりました。
原因
Webサーバーで「ドキュメントモード」として「7」「8」「9」が指定されている可能性があります。
ドキュメントモードとは、Webサーバー側の設定で「Internet Explorerの振る舞い」を指定するものです。表示が崩れてしまうような古いWebサイトを最近のブラウザで表示させるために設定されることがあります。このドキュメントモードが「7」「8」「9」となっている場合、コンテンツを表示することができません。
確認方法
この原因に該当するかどうかは、以下の方法でご確認ください。
- Internet Explorerを起動します。
- ツールメニュー(右上歯車マーク)をクリック
- [F12 開発者ツール]をクリック
- Internet ExplorerのURL欄に、該当のコンテンツのURLを入力
- 開発者ツールウィンドウの上部の表記を確認
「7」「8」「9」が表示されている場合、この問題に該当します。
回避策
上記が該当する場合、コンテンツ側では対応することはできません。回避策は以下のいずれかになります。
- 閲覧者がInternet Explorer以外のブラウザを利用する。
- Webサーバーのドキュメントモードを Edge(または11)に変更する。
ご参考として、Webサーバー管理者の方に確認を依頼する文面案をご用意しました。必要にあわせてご利用ください。
ーーー ここから ーーー
○○○○○○のサーバーにアップロードしているHTML5で動作する以下のコンテンツを閲覧しようとしたら閲覧できません。
コンテンツURL: ****
以下のURLで指示されている方法で確認したところ、Webサーバーのドキュメントモード設定が関係している可能性があります。
参考URL: https://lwsupport.zendesk.com/hc/ja/articles/4404181102745
コンテンツがアップロードされているサーバー側の設定で、ドキュメントモードを解除することは可能でしょうか?
ーーー ここまで ーーー
発生条件
Internet Explorerで発生します(Google ChromeやFireFoxでは閲覧できます)
関連情報
Windows 10 の Internet Explorer 11 デスクトップアプリは 2022/6/15にサポートが終了します。