現象
過去に書き込んた付箋やメモの情報が消えてしまった。
回答
FLIPPERで作成したブックデータを一般的なWebサーバーに公開している場合、付箋やメモの情報はブラウザのlocalStorageにブック毎(コンテンツID)に情報が保存されています。
このデータは、同じブラウザかつ同じデバイスでのみアクセス可能であり、再度同じ条件でアクセスすると、以前のメモが表示される仕組みとなっています。
消えてしまった原因は以下のとおりです。
- 回答(1)別のブラウザからアクセスしている
- 回答(2)ブラウザのキャッシュをクリアしている
- 回答(3)別のブックを閲覧している
- 回答(4)プライベートブラウザで閲覧している
- 回答(5)ドメイン名を変更した
- 回答(6)HTTPからHTTPSに切り替えた
- 回答(7)コンテンツIDが異なるブックで更新している
- 回答(8)FLIPPER Uのブックに対してFLIPPER U2のブックで上書き更新した
- 回答(9)ブックの版数を更新した ※Libra V利用者限定
回答(1)別のブラウザからアクセスしている
原因
付箋やメモを書いた時のブラウザと異なるブラウザでブックを閲覧ししている可能性があります
(例:Microsoft Edgeで付箋やメモを書きこみ、その後同じブックをGoogle Chromeで開く)
参考情報)
モバイルで閲覧した場合、アプリ内ブラウザ(※)で付箋・メモを書いた後に同じブックをSafariやGoogle Chromeで開いても情報が引き継がれませんのでご注意ください。
※アプリ内ブラウザとは?
FacebookやTwitter、LINEなどのアプリ内で「http://」または「https://」から始まる文字列をクリックしたときに表示されるブラウザです。
回避策
付箋やメモを書き込んだ時のブラウザでブックを閲覧してください。
回答(2)ブラウザのキャッシュをクリアしている
原因
ブラウザのキャッシュをクリアしている可能性があります。
※キャッシュクリアを行う際、「Cookieおよびその他サイトデータ」にチェックを付けてクリアした場合、付箋メモが保存されているlocalStorage領域の情報が消えてしまいます。
回避策
事前に注意喚起をおこなうなど対策をお願いいたします。
回答(3)別のブックを閲覧している
原因
付箋やメモの情報は各ブック毎に保存されます。
その為、付箋やメモを書いた時のブックと異なるブックを閲覧している可能性があります。
回避策
同じブックを閲覧してください。
回答(4)プライベートブラウザで閲覧している
原因
プライベートブラウザでブックを閲覧している可能性があります。
プライベートブラウザは、閲覧履歴、Cookie、閲覧履歴等を保存させない仕組みの為、プライベートブラウザを終了すると削除されます。この影響で付箋やメモの情報も保存する事ができません。
確認方法
ブラウザを以下の手順で開いた場合、プライベートブラウザに該当します。
■ PC
Microsoft Edge:画面右上にある「設定ボタン」→ 新しいInPrivateブラウズ
Google Chrome:画面右上にある「設定ボタン」→ シークレットウィンドウを開く
Firefox:画面右上にある「メニューボタン」→ 新しいプライベートウィンドウ
■ モバイル
Safari:iPhoneでsafariを開く → 画面左下の「プライベート」をタップ
回避策
プライベートブラウザは使用しないでください。
回答(5) ドメイン名を変更した
原因
公開先のドメイン名が変更された可能性があります。
ドメイン名が変更された場合、変更前のLocalStorageにアクセスが不可となるため、今までの付箋やメモ情報への参照ができなくなり、消えてしまいます。
回避策
ドメイン名を更新する際は注意喚起をおこなうなど対策をお願いいたします。
回答(6)HTTPからHTTPSに切り替えた
原因
公開先のWebサイトが「HTTP」から「HTTPS」に変更された可能性があります。
HTTP から HTTPS へ切り替えた場合、変更前のLocalStorageにアクセスが不可となるため、今までの付箋やメモ情報への参照ができなくなり、消えてしまいます。
回避策
切り替えをされる前に注意喚起を行うなど対策をお願いいたします。
回答(7)コンテンツIDが異なるブックで更新している
原因
コンテンツIDが異なるブックデータで上書き更新している可能性があります。
今まで書き込んだ付箋メモが残る条件は、以下の通りです。
- 更新前とコンテンツIDが同一であること(※)
- 同一URLにアクセスしていること
- 同一ブラウザでアクセスしていること
※1 同じ内容のブックを以下の方法で作り直した場合、コンテンツIDが変わります。
- 新規作成画面から一から作り直している
- バックアップファイルをFLIPPER U2にインポート後、再編集している
- コンテンツの複製機能を使って再編集をしている
回避策
初版で作成したブックの編集画面を開き、ページ差し替え・追加などで編集を行ってください。
この方法で編集を行っていただければコンテンツIDは変わりません。
尚、ページを差し替えをする場合、ページ編集画面の「+差し替え」から行ってください。
※差し替えたいページを削除 → ページ追加(または、ページ追加 → 差し替えたいページを削除)の手順でページを更新(結果的に差し替わった状態)した場合は、更新した際に貼り付けた付箋やメモの位置がずれるケースがあります。
回答(8)FLIPPER Uのブックに対してFLIPPER U2のブックで更新した
原因
FLIPPER Uで作成したブックに対して、FLIPPER U2で作成したブックで上書き更新した可能性があります。
FLIPPER UとFLIPPER U2のブックは、閲覧上の見た目は同様となります。
しかし、裏側の動作が異なるため、FLIPPER UのブックをFLIPPER U2で版更新すると付箋・メモの書き込み情報を引き継ぐことができず消えてしまいます。
回避策
FLIPPER Uのブックに対しての更新は、FLIPPER Uで作成したブックで更新を行ってください。
回答(9)ブックの版数を更新した ※Libra V利用者限定
原因
ブックコンテンツの版を更新した可能性があります。
付箋やメモは版毎(コンテンツ毎)で保存している為、付箋やメモを書いた時の版と異なる版を閲覧している可能性があります。
発生条件
- 付箋・メモの保存先が「ブラウザ内(Local Storage)」に設定されている場合に発生します。
回避策
Libra V 2.4.0(2018年10月2日リリース)から付箋・メモの情報をLibra Vに保存できる仕組みが実装されました。版追加時に付箋・メモを引き継ぎたい場合は付箋・メモの保存先を「Libraサーバー内」で運用してください。
※FLIPPER U 4.6.0以降で作成されたブック、またはFLIPPER U2で作成されたブックである事が条件。
付箋・メモの保存先を「Libraサーバー内」にした場合、以下のメリットがあります。
- 版を追加した場合でも一つ前の版に書き込んだ付箋・メモデータが引き継がれます。
- 閲覧ブラウザが変わってもログインアカウントが同一であれば書き込んた付箋・メモが閲覧できます。