現象
過去に書き込んた付箋やメモの情報が消えてしまった。
回答
FLIPPERで作成し、一般的なWebサーバーに公開している電子ブックの場合、付箋やメモの情報は閲覧しているブラウザのlocalStorageに保存されます。この情報は、ブックごとにコンテンツIDで管理されています。
以前に書き込んだ付箋やメモが再び表示されるのは、以下の条件がすべて一致している場合です。
- ブックのコンテンツIDが同じであること
- 同じブラウザで閲覧していること
- 同じデバイスで閲覧していること
これらの条件が一致することで、localStorageに保存されたデータが読み込まれ、以前のメモが表示されます。
消えてしまった原因は以下のとおりです。
- 回答(1)別のブラウザからアクセスしている
- 回答(2)ブラウザのキャッシュをクリアしている
- 回答(3)別のブックを閲覧している
- 回答(4)プライベートブラウザで閲覧している
- 回答(5)ドメイン名を変更した
- 回答(6)HTTPからHTTPSに切り替えた
- 回答(7)コンテンツIDが異なるブックで更新している
- 回答(8)FLIPPER Uのブックに対してFLIPPER U2のブックで上書き更新した
- 回答(9)ブックの版数を更新した ※Libra V利用者限定
回答(1)別のブラウザからアクセスしている
原因
付箋やメモを書き込んだ時と異なるブラウザでブックを閲覧している可能性があります。
例: Microsoft Edgeで付箋やメモを書き込んだ後、同じブックをGoogle Chromeで開いた場合、メモは表示されません。
参考情報)
モバイルで閲覧した場合、アプリ内ブラウザ(※)で付箋・メモを書いた後に同じブックをSafariやGoogle Chromeで開いても情報が引き継がれませんのでご注意ください。
※アプリ内ブラウザとは?
モバイルデバイスの場合、FacebookやX、LINEなどのアプリ内ブラウザ(アプリ内でhttps://から始まるリンクをクリックした際に表示されるブラウザ)で付箋・メモを書き込んだ後、SafariやGoogle Chromeといった標準ブラウザで同じブックを開いても情報は引き継がれませんのでご注意ください。
回避策
付箋やメモを書き込んだ際の同じブラウザでブックを閲覧してください。
回答(2)ブラウザのキャッシュをクリアしている
原因
お使いのブラウザのキャッシュをクリアした可能性があります。
特に、キャッシュクリアを行う際に「Cookieおよびその他サイトデータ」の項目にもチェックを入れて実行した場合、付箋やメモが保存されているLocalStorage領域の情報も同時に削除されてしまいます。
回避策
ブラウザのキャッシュをクリアする際は、「Cookieおよびその他サイトデータ」のチェックを外すようユーザーに注意を促すなど、事前の対策をご検討ください。
回答(3)別のブックを閲覧している
原因
付箋やメモの情報は、各ブック(コンテンツID)ごとに保存されます。そのため、付箋やメモを書き込んだブックとは異なるブックを閲覧している可能性があります。
回避策
付箋やメモを書き込んだ同じブックを閲覧してください。
回答(4)プライベートブラウザで閲覧している
原因
プライベートブラウザ(シークレットモード、InPrivateブラウズなど)でブックを閲覧している可能性があります。
プライベートブラウザは、閲覧履歴、Cookie、サイトデータなどを保存しない設計のため、ブラウザを閉じるとこれらの情報が削除されます。この特性により、付箋やメモの情報も保存されません。
確認方法
ブラウザを以下の手順で開いた場合、プライベートブラウザに該当します。
■ PC
Microsoft Edge:画面右上の「設定ボタン」→ 新しいInPrivateブラウズ
Google Chrome:画面右上の「設定ボタン」→ シークレットウィンドウを開く
Firefox:画面右上の「メニューボタン」→ 新しいプライベートウィンドウ
■ モバイル
Safari:iPhoneでsafariを開く → 画面左下の「プライベート」をタップ
回避策
付箋やメモを保存したい場合は、プライベートブラウザを使用しないでください。
回答(5) ドメイン名を変更した
原因
ブックが公開されているWebサーバーのドメイン名が変更された可能性があります。
ドメイン名が変更されると、変更前のLocalStorageにはアクセスできなくなるため、以前の付箋やメモ情報が参照できなくなり、消えてしまいます。
回避策
ドメイン名を変更する際は、ユーザーに付箋やメモの情報が失われる可能性があることを事前に注意喚起するなどの対策をご検討ください。
回答(6)HTTPからHTTPSに切り替えた
原因
公開先のWebサイトのプロトコルが「HTTP」から「HTTPS」に切り替えられた可能性があります。
HTTPからHTTPSに切り替わると、プロトコル変更前のLocalStorageにはアクセスできなくなるため、以前の付箋やメモ情報が参照できなくなり、消えてしまいます。
回避策
プロトコルを切り替える前に、ユーザーに付箋やメモの情報が失われる可能性があることを事前に注意喚起するなどの対策をご検討ください。
回答(7)コンテンツIDが異なるブックで更新している
原因
既存のブックデータに対して、コンテンツIDが異なる新しいブックデータで上書き更新している可能性があります。
付箋やメモが保持される条件は以下の通りです。
- 更新前とコンテンツIDが同一であること
- 同一URLにアクセスしていること
- 同一ブラウザでアクセスしていること
注意:
同じ内容のブックであっても、以下の方法で作成し直した場合、コンテンツIDが変わってしまいます。
- 新規作成画面から一から作り直している
- バックアップファイルをFLIPPER U2にインポート後、再編集している
- コンテンツの複製機能を使って再編集をしている
回避策
初版で作成したブックの編集画面を開き、ページ差し替えやページ追加などの方法で編集を行ってください。この方法で編集を行えば、コンテンツIDは変わりません。
尚、ページを差し替えをする場合、ページ編集画面の「+差し替え」から行ってください。
※差し替えたいページを削除 → ページ追加(または、ページ追加 → 差し替えたいページを削除)の手順でページを更新(結果的に差し替わった状態)した場合は、更新した際に貼り付けた付箋やメモの位置がずれるケースがあります。
回答(8)FLIPPER Uのブックに対してFLIPPER U2のブックで更新した
原因
FLIPPER Uで作成したブックを、FLIPPER U2で作成したブックで上書き更新した可能性があります。FLIPPER UとFLIPPER U2のブックは、見た目は同じですが、内部的な動作が異なります。
そのため、FLIPPER UのブックをFLIPPER U2のブックで版更新すると、付箋・メモの書き込み情報を引き継ぐことができず消えてしまいます。
回避策
FLIPPER Uで作成したブックを更新する場合は、FLIPPER Uで作成したブックデータで更新を行ってください。
回答(9)ブックの版数を更新した ※Libra V利用者限定
原因
ブックコンテンツの版を更新した可能性があります。
付箋やメモは版毎(コンテンツ毎)で保存している為、付箋やメモを書いた時の版と異なる版を閲覧している可能性があります。
発生条件:
付箋・メモの保存先が「ブラウザ内(Local Storage)」に設定されている場合に発生します。
回避策
Libra V 2.4.0(2018年10月2日リリース)以降では、付箋・メモの情報をLibra Vサーバーに保存できる仕組みが実装されています。
版を追加した際に付箋・メモを引き継ぎたい場合は、付箋・メモの保存先を「Libraサーバー内」で運用してください。
※この機能は、FLIPPER U 4.6.0以降で作成されたブック、またはFLIPPER U2で作成されたブックが対象です。
付箋・メモの保存先を「Libraサーバー内」に設定することには、以下のメリットがあります。
- 版を追加した場合でも、一つ前の版に書き込んだ付箋・メモデータが引き継がれます。
- 閲覧するブラウザが変わっても、ログインアカウントが同一であれば、書き込んだ付箋・メモを閲覧できます。