現象
「配信を開始する」をクリックしたら、「エンコーディング中にエラーが発生しました」と表示され、セミナー内で映像配信が行えない。
回答
回答は以下の通りです。
トラブルが解決しない場合は?
本記事でご案内している内容で解決ができなかった場合は「解決できない場合は?」ご確認ください。
回答(1)カメラ・マイクが他のアプリケーションで利用されている
原因
セミナー配信ツールで選択したカメラ・マイクが他のアプリケーション(主にGoogleMeet、Teams、Skype、Zoom等のWeb会議システム)で利用されていると、セミナー配信ツール側でエラーが発生し、エンコードエラーが表示されます。
回避策
原因となっているアプリケーションを次の手順で終了させ、セミナー配信ツールを再起動してください。
■対応手順
1)カメラ・マイクを利用していると思われる、他のアプリケーションを閉じる
2)タスクトレイを確認し、他のアプリケーションを終了する
3)セミナー配信ツールを再起動する
回答(2)セキュリティによりGigaCastへの通信が行えない
原因
配信PCが接続しているネットワークのセキュリティチェック制限により、GigaCast(配信サーバ)への通信が阻害されている可能性があります。GigaCastの配信には、1935ポート、RTMPプロトコル、ドメインのアクセスの許可が必要です。
回避策
回避策は、以下の2パターンになります。
A. 別のインターネット回線をご利用下さい。
B. インターネット回線の管理者に、下記の設定をご確認ください。
以下、設定内容となります。
※実際の設定は、情報システムのご担当者にご依頼下さい。
■接続先ドメイン
「*.di.gigacast.tv」もしくは「*.gigacast.tv」
※お使いのファイアウォールの仕様に合わせてください。
※GigaCastCloudはクラウドサービスの為、固有のIPではなくドメイン単位での通信許可が必要です。
■プロトコル/ポート
・プロトコル:TCP
・ポート:1935 (RTMP)、方向:OUT
■その他
稀にプロキシサーバーで、一定時間を過ぎると通信を遮断する設定になっていることがあります。
その際は、上記通信時は遮断処理を行わないよう設定してください。
技術資料:GigaCast共有クラウド利用のための通信許可のお願い(社内ネットワーク管理者の方へ)
回答(3)パソコンがQSVに対応していない
原因
GigaCastの映像配信で有効なハードウェアエンコードは、QSV(Intel® Quick Sync Video)方式に限定されます。他の方式のハードウェアエンコード(NVidia NVENC、AMD VCEなど)を持つパソコンでは映像配信が行えません。
ご利用のパソコンがいずれかの条件に該当する場合は、QSV非対応の可能性があります。
以下の回避策をお試しください。
- QSV方式以外のハードウェアエンコード(NVidia NVENC、AMD VCEなど)を持つパソコンを利用する場合
- ハードウェアエンコード機能を持たない古いIntel CPUを(おおよそ、2011年以前に製造されたパソコン)
回避策
- GigaCast セミナー配信ツールの配信設定画面で「HTML版の配信にハードウェアエンコードを使用する」のチェックを外してください。詳しい方法はこちらのページをご確認ください。