現象
コンテンツ作成ソフトで書き出した「index.html」をブラウザで開くとエラーが出て閲覧できない。
[アラート内容]
データがパソコン内にある状態では、正常に閲覧できません。
作成されたコンテンツのデータは、「ロゴスウェアローカルビューアー」を使用するかウェブサイトにアップロードして閲覧してください。
回答
原因
このアラートは、作成されたコンテンツデータのindex.htmlを、お使いのパソコンのデスクトップやダウンロードフォルダなど、ローカル環境から直接ブラウザで開こうとした場合に表示されます。
コンテンツ作成ソフト(FLIPPER U2、STORM Xe、THiNQ Xe)から書き出したデータは、基本的にインターネット上のWebサーバーに公開して閲覧されることを前提に作られています。
そのため、パソコンのローカル環境では正しく動作しない仕組みになっています。
回避策
以下のいずれかの方法でコンテンツを閲覧してください。
-
LOGOSWAREローカルビューアーを利用する
Webサーバーにアップロードする前に、ご自身のパソコンで一時的に動作確認をしたい場合に便利なツールです。下記のダウンロードページから「LOGOSWAREローカルビューアー」をインストールしてご利用ください
ローカルビューザーをダウンロードする
https://learning.logosware.com/soft/lv
-
Webサーバーにアップロードする
「LOGOSWAREローカルビューアー」のインストールが難しい場合は、作成したコンテンツデータをWebサーバーにアップロードしてください。アップロード後、公開用のURLからアクセスすることで、コンテンツを閲覧・動作確認できます。
関連記事:コンテンツを自社のホームページ(Webサイト)で公開する方法
トラブルが解決しない場合は?
本記事でご案内している内容で解決ができなかった場合は「解決できない場合は?」をご確認ください。