現象
スコア管理画面内の「結果簡易集計画面」を確認すると、問題テキストや選択肢テキストが「データ取得できません」と表示され確認する事ができません。
また、「問題ID」や「回答内容(選択肢ID)」が1、2、3・・・・と連番に表示されていないケースもあるため、「問題ID」や「回答内容(選択肢ID)」の数字が、THiNQ Xe上の「どの問題」または「どの選択肢」にあたるのか分かりません。
回答
原因
該当のTHiNQコンテンツがWebサーバー上で公開されてない場合、参照先のデータがないため
「データ取得できません」と表示されます。
※ 過去にWebサーバー上で公開していたとしても該当のTHiNQコンテンツがWebサーバーから削除された時点で「データ取得できません」の状態になります。
また、スコア管理画面上に表示されている「問題ID」や「回答内容(選択肢ID)」はTHiNQ Xe上で編集する際、問題文や選択肢を削除したり並び替えをすると、スコア上に表示されるIDが順不同になります。
回避策
以下のいずれかでご対応ください。
1)コンテンツを再アップロードする
以下の作業をしていただくことで、「データ取得できません」が解消され、順不同で表示されたIDに紐づく問題、選択肢が表示されるようになります。
- Webサーバーに再度同じコンテンツ(書き出し時のコンテンツ管理IDを同一にする)をアップロードしてください。
- 一回だけダミーでテストを受けてください。
- スコアの管理画面にアクセスして、解消されている事を確認します。
2)data.jsを確認する
「データ取得できません」と表示される問題は、コンテンツの再アップロードが必須となります。
コンテンツの再アップロードができない場合で、スコア管理画面上に表示されている「問題ID」や「回答内容(選択肢ID)」の数字が、THiNQ Xe上の 「どの問題」または「 どの選択肢」にあたるのか判断したい時にはコンテンツデータ内のdata.js内の値でご判断ください。
- Webサーバーにアップロードしたコンテンツデータ内の「date.js」をテキストエディタで開きます。(dateフォルダ>date.js)
- 以下の値で問題ID、選択肢IDを判断する事ができます。
"questionSettingList"配下の"id" ⇒ 問題ID
"ch_list"配下の"id" ⇒ 選択肢ID
トラブルが解決しない場合は?
本記事でご案内している内容で解決ができなかった場合は「解決できない場合は?」ご確認ください。