現象
Platon管理画面の[進捗]>[進捗出力]で進捗CSVをzip形式でダウンロードしました。そのzipファイルを解凍したところ、解凍先のフォルダにファイルがなく、空の状態になっています。
なぜ進捗CSVが空になっているか、原因と回避策を知りたいです。
回答
回答は以下のとおりです。
トラブルが解決しない場合は?
本記事でご案内している内容で解決ができなかった場合は「解決できない場合は?」をご確認ください。
回答(1)対象の受講者にコースが割当たっていない
原因
対象の受講者にコースが割当たっていない可能性があります。
進捗CSVは、受講者の方に【コースが割り当たっている】場合に出力されます。
コース割り当てを外した場合は出力対象となるCSVがなく、空のZIPファイルがダウンロードされます。
回避策
再度、進捗CSVを取得したい受講者にコース割り当てを実施してください。
その後、進捗CSVをダウンロードしてください。
発生条件
- コース割り当てを外している
回答(2)対象の受講者数が多すぎる
原因
進捗を出力する対象の受講者数が数千人規模となった場合、進捗CSVが出力できずに空のZIPファイルがダウンロードされることがあります。
回避策
組織を抽出し、出力対象の受講者数を減らしてから進捗CSVをダウンロードしてください。
または、「予約して後でダウンロード」をご利用ください。
発生条件
- 対象の受講者数が多すぎる